ML 2.0: Advent of Decay Quality Issues

Re: ML 2.0: Advent of Decay Quality Issues

Postby zombie13 » Wed May 08, 2019 10:28 pm

You may be surprised at the things some people can complain about. I've seen some of it myself. Some things are minor in my eyes, but others expect their figures to be flawless. It can be frustrating when you're missing something, it's happened to me too. I've had nothing but good experience with the Horsemen in resolving issues with my stuff. Sometimes it just takes a little bit of time and patience. They are not a big corporation and at times, it's just a handful of people sifting through everything that they have to do on a daily basis. It's best to remember that a little bit of patience goes a long way. I know it's hard when you have an issue and it seems like they will never respond to you, but I've never known the 4H to ever flat out ignore anyone.
Anyone that needs me off site or not a registered member here may email me at zombie13.customs@yahoo.com
Follow me on Instagram at zombie13.customs
User avatar
zombie13
Smith
 
Posts: 2725
Joined: Wed Jul 17, 2013 9:57 am
Location: Slidell, Louisiana

Re: ML 2.0: Advent of Decay Quality Issues

Postby Gowron » Sat Jun 01, 2019 1:01 am

So, did anyone get any shipping notice for their QC issues before the announcement that Soul Spiller is shipping? I didn't
Gowron
Silver Grunt
 
Posts: 441
Joined: Fri Oct 21, 2016 2:26 pm
Location: Denver, Colorado

Re: ML 2.0: Advent of Decay Quality Issues

Postby Cythagen » Sat Jun 01, 2019 5:28 am

Gowron wrote:So, did anyone get any shipping notice for their QC issues before the announcement that Soul Spiller is shipping? I didn't


Me, neither. I did get an acknowledgement that my issue is being resolved, but no time-table or shipping info was provided.
Cythagen
Bronze Grunt
 
Posts: 142
Joined: Sun Jun 23, 2013 1:12 am
Location: San Diego, CA

Re: ML 2.0: Advent of Decay Quality Issues

Postby jscott991 » Sat Jun 01, 2019 11:36 am

I never got a response to any of emails or inquiries.
User avatar
jscott991
Silver Grunt
 
Posts: 343
Joined: Wed Feb 07, 2018 10:31 am

Re: ML 2.0: Advent of Decay Quality Issues

Postby ASMDaniel » Tue Jun 04, 2019 11:04 am

I did want to update to say that they replied and sent the parts that I still needed. Very much appreciated!
ASMDaniel
Silver Grunt
 
Posts: 349
Joined: Fri May 20, 2016 9:41 pm

Re: ML 2.0: Advent of Decay Quality Issues

Postby Gowron » Tue Jun 04, 2019 3:46 pm

ASMDaniel wrote:I did want to update to say that they replied and sent the parts that I still needed. Very much appreciated!


Congrats. I'm still waiting for a response. My soul spiller order is on the way, so hopefully they threw my items in with that shipment. But I doubt it , I don't believe they are organized enough to do that.
Gowron
Silver Grunt
 
Posts: 441
Joined: Fri Oct 21, 2016 2:26 pm
Location: Denver, Colorado

Re: ML 2.0: Advent of Decay Quality Issues

Postby Cythagen » Tue Jun 04, 2019 6:57 pm

ASMDaniel wrote:I did want to update to say that they replied and sent the parts that I still needed. Very much appreciated!


Questions:
Did they provide any tracking info for the parts you received?
What was the turnaround time between their reply and the delivery of said parts?

They emailed me on May 7th to say my missing figure would be shipped "as soon as possible," but I haven't gotten anything since then.
Cythagen
Bronze Grunt
 
Posts: 142
Joined: Sun Jun 23, 2013 1:12 am
Location: San Diego, CA

Re: ML 2.0: Advent of Decay Quality Issues

Postby Jundie » Tue Jun 04, 2019 9:18 pm

I have sent 2 emails. The last being April 12th about 5 pairs of missing wings. I have not even received an email.
Feel free to email me: wrpost@gmail.com
Jundie
 
Posts: 36
Joined: Tue Jan 30, 2018 4:52 pm

Re: ML 2.0: Advent of Decay Quality Issues

Postby crazybirdman » Thu Jun 20, 2019 3:55 pm

Can someone tell me if I'm doing something wrong? My skeletal wings I got with the birds don't fir either of the wing adapters :(

Image

Image
User avatar
crazybirdman
Silver Grunt
 
Posts: 445
Joined: Mon Jul 15, 2013 6:20 pm

Re: ML 2.0: Advent of Decay Quality Issues

Postby Satam » Thu Jun 20, 2019 10:06 pm

crazybirdman wrote:Can someone tell me if I'm doing something wrong? My skeletal wings I got with the birds don't fir either of the wing adapters :(

Image

Image


Do the mushroom pegs seem just slightly too large? I would try heating up the adapter with a hair drier a little and then try inserting the wings.
User avatar
Satam
Bronze Grunt
 
Posts: 199
Joined: Fri Jun 21, 2013 12:09 pm

Re: ML 2.0: Advent of Decay Quality Issues

Postby worldwar_hulk » Fri Jun 21, 2019 2:35 am

Yep, it's definitely that 2nd one with the smaller holes. You just gotta jam em in there, or use heat. Be sure cool it down with cold water after the heat.
worldwar_hulk
Silver Grunt
 
Posts: 398
Joined: Sun Jul 14, 2013 1:21 pm

Re: ML 2.0: Advent of Decay Quality Issues

Postby Satam » Fri Jun 21, 2019 8:25 pm

I usually just let stuff like that cool in the air. No problems so far.
User avatar
Satam
Bronze Grunt
 
Posts: 199
Joined: Fri Jun 21, 2013 12:09 pm

Re: ML 2.0: Advent of Decay Quality Issues

Postby crazybirdman » Mon Jun 24, 2019 8:23 am

worldwar_hulk wrote: You just gotta jam em in there, or use heat.


Thank you! That worked great :mrgreen:
User avatar
crazybirdman
Silver Grunt
 
Posts: 445
Joined: Mon Jul 15, 2013 6:20 pm

Previous

Return to Mythic Legions Kickstarter & Fantastic Exclusive

Who is online

Users browsing this forum: No registered users and 1 guest

cron